kein DSF Empfang Astra

Keine Ahnung… seit Ewigkeiten ging bei uns im Wohnzimmer kein DSF mehr. Egal welchen Receiver ich auch anschloss, immer nur ein zuckendes Bild.

Gestern hatte ich dann die Nase voll…. auch in Hinblick auf die Übertragung der Hallenturnier-Saison im DSF 2010 :)… und fand nach längerem googlen ein äußerst lustigen DECT-BUG, der sich scheinbar nur auf DSF und TELE5 auswirkte (…wer braucht schon TELE5 :-)).

In Dem Artikel wurde beschrieben, dass manche Telefone das Signal stören könnten?! WOS?!

Also einfach mal schnell das komplette Telefon, inkl. Ladeschale ausgeschaltet und DSF angemacht.

BOAH! Geht wieder… ROFL!

Also, wenn bei uns mal jemand nicht dran geht und auch kein AB anspringt, dann guck ich DSF 🙂

Mal schauen, ob es noch einen anderen WorkAround gibt… vielleicht Telefon weiter weg stellen oder irgendwie abschirmen, oder durch ein neues Telefon austauschen.

.co.de Domain Abzocke?

Auch ich bekam Post von der Firma „Websuche Search Technology GmbH & Co. KG“. Wie heise.de schon berichtete empfand ich das Anschreiben als nicht sonderlich gelungen.

Einzige gute Aussage war:

…da Sie mit www.seo-ranking-tools.de eine der wichtigsten Seiten im deutschen Markt betreiben…

… schon lustig! 🙂

Ansonsten kann ich mich nur heise anschließen. Wer nen Schreiben rausschickt, wo zu lesen ist: „Rechtliche Klärung wegen www.domain.de“, der hat nicht gleich meine Zustimmung geweckt.

Außerdem wird in dem Schreiben nicht im geringsten darauf hingewiesen, dass es sich bei der Domainbestellung für 99 EUR um eine Subdomain handelt… LOL! Ich geb für ne dumme Subdomain doch keine 99€ aus!

Enjoy FloodBot based on OverKill… not in my house!

Vor kurzem war die Auslastung eines Web-Servers extrem hoch, so auch heute den ganzen Tag. Also machte ich mich auf die Suche nach der Ursache und stolperte über eine lustige Sicherheitslücke im „phpMyAdmin“ worüber sich ein FloodBot einschlich. Er nutze eine Datei worüber er schön den Bot mit passender Berechtigung herunterlud und ausführte. Ich war doch ein wenig verwundert und probierte das gleich an einem Testsystem aus.

Jo! Dickes Ding…

Schwupps, war der Bot drauf und startete. Das sah dann per „ps aux“ so aus:

bot1Den genauen Befehl gebe ich hier mal nicht Preis. Wer weiß wer was damit bei anderen anrichten möchte.

 

Wow!… immer noch erstaunt :-).

Die Datei udp.pl mithilfe der Lücke und „sh -c perl“ über die config.inc.php von phpMyAdmin einfach gestartet.

Irre!

Die Lücke ist so riesig, dass man über ein paar witzige Handgriffe den Server darüber so gut wie steuern kann (Vorausgesetzt man hat bei der Rechtevergabe geschlampt!). Mit Aufruf: 
http://…/php_my_admin/config/config.inc.php?p=phpinfo(); kann man sich schön die Komplettinfo zum Server holen oder mit http://…/php_my_admin/config/config.inc.php?c=ps%20aux den Inhalt des tmp-Ordners. Dieser war in diesem Fall angefüllt mit dem BOT.

bot2

Mehr poste ich nicht, animiert nur zu wilden Gedanken :-). Habs aber gleich auf befreundeten Systemen mal ausgetestet und siehe da, viele haben die Lücke nicht geschlossen. Denjenigen habe ich mal schnell ne Mail geschrieben.

 

Schnell mal mit „last -i“ nach komischen Logins gefahndet, dann noch known_hosts und ssh-key’s überprüft und die /etc/passwd nach lustigen neuen Usern mit UIDs „0“ durchsucht. War aber nix ungewöhnliches. Glück gehabt. Schnell phpMyAdmin aktualisiert, die tmp-Verzeichnisse geleert, und restliche Komponenten wie php, apache usw. aktualisiert und Server neu gestartet (Windows angewohnheit :-)).
Nun noch mit „apt-get rkhunter install“ nen RootKitHunter installiert und das System durchgecheckt und mit „netstat -nap“ und „netstat -tulpe“ die Ports gecheckt … Und auch alles in Ordnung.
Anschließend den eaccelerator neu kompiliert und schwupps… Livesystem nach 3 Stunden wieder clean. Downtime… summiert ca. 5 min… klasse Job! Blog schreiben 30 min :-). Schöner Sonntagabend.

Anschließend Serverseitig noch weitere Möglichkeiten mit ein paar Tricks unterbunden. Alles soll man nicht verraten :-).

Was ich daraus gelernt habe:

  1. Öfters mal ins Error und Accesslog vom Apachen schauen,
  2. apt-get upgrade/update/install sollte ein Freund werden,
  3. … meine Linux-Kenntnisse sind noch gut 🙂

Wollen wir mal schauen, ob das alles war. Der Server bleibt die Tage unter Beobachtung.

SPAM oder „Wink mit dem Zaunpfahl“

Neulich, spät Abends, bekam ich eine E-Mail von einem Kollegen, der sich darüber aufregte, dass er diese persönlichen E-Mails übers Abnehmen bekommt.
Sein Wortlaut (verkürzte Fassung):

„…Ich weiß, ich bin dick und ich versuche auch etwas dagegen zu machen, aber ich finde es unverschähmt, dass ihr mich andauernd durch diese Mails daran erinnert. Wer auch immer mich in den Verteiler eingetragen hat, den will ich sagen das ich schon alles versuche um abzunehmen…“

Bei genauerm Hinsehen sah ich, dass die E-Mail an viele Mitarbeiter geschickt wurde… *breites Grinsen auf meinem Gesicht*!

… Habe ihm dann versucht zu erklären, dass das SPAM ist, und das solche Mails immer mal wieder durch unsere SPAM-Filter rutschen.

#potentielles Phishing Opfer
#autsch… Lacher No.1 in der Firma
#Beispiel für eine Person die auch auf SPAM-Mails hin etwas per Kreditkarte bestellt. Dank solchen Leuten stribt SPAM niemals aus 🙂