IE7 installation failed… WARUM?! & Lösung

Seit längerem habe ich das Problem, dass sich der IE 7 (Internet Explorer 7) bei manchen Windows XP- Clients nicht installieren lässt.
Bis vor kurzem war mir das rechte egal, aber jetzt waren dann doch ein paar mehr Rechner betroffen und ich wollte unbedingt die 100% beim Patchstand der Clients auf dem WSUS Server erreichen. Also machte ich mich dran und wertete die Logfiles, das Ereignismanagment usw. auf den einzelnen Clients aus.
Selbst die vielen Treffer bei Google und bei der Knowledgebase von MS brachten keinen Lösungsansatz.

Immer wieder kam die Meldung:

Fehlermeldung „Internet Explorer konnte nicht installiert werden“ beim Versuch, Internet Explorer 7 zu installieren

Anschließend wurde auf dem Desktop eine HTML-Datei mit dem Namen „Internet Explorer-Problembehebung“ abgelegt, die aber seit neustem keine Infos zum Beheben des Fehlers beinhaltet sondern direkt nen Ticket bei Microsoft für 80 EUR aufmachen will :-). Auch Microsoft weiß, wie man in der schweren Zeit der Wirtschaftskriese sein Geld machen kann :-).

Im LogFile vom IE7 (sucht auf eurem Rechner nach „ie7.log“) stand immer was von „Unwriteable keys“, was mich auf die Idee brachte, ob eine andere Application den Install/Update Prozess unterbricht. Und siehe da, es war eine sehr, sehr böse Software :-)…

LÖSUNG:

Kurz den Adobe Acrobat Reader 9.x deinstallieren, IE7 installieren und wieder den Adobe 9.x installieren… fertig

Das war nicht das erste Mal, dass ein Adobe Anwendung ein Installprozess einer anderen Software oder aber die komplette Funktionalität einer anderen Software blockierte… was machen die denn da nur?

Adobe FlashPlayer 10 blockiert T-Mobile web’n’walk Manager

Die Außendienstler bei uns hatten auf einmal fast zeitgleich das Problem, dass die Application web’n’walk Manager von T-Mobile gar nicht mehr startete.
Mein erster Gedanke war, dass irgendein Windows Update dort quergeschlagen hat. Der Verdacht bestätigte sich, als nach einer Systemwiederherstellung von Windows Xp die Software wieder funktionierte… Ich stellte Windows Updates aus und nach 2 Tagen war das Problem wieder da…

WOS?!? Doch kein Windows Update Problem…
Ne… war es nicht, aber der Adobe Flashplayer 10.x, der sich automatisch bei den meisten Notebooks installierte, war das Problem. Die neue Version blockierte komplett die web’n’walk Manager Application. Kurz das Update von T-Mobile eingespielt und fertig (Update angestoßen mit Hilfe der Update-Datei unter C:ProgrammeT-Mobileweb’n’walk Manager)…

PS: Wer klug war und bei der UMTS-Karteneinrichtung nix falsch gemacht hat und die automatischen T-Mobile Updates zugelassen hat, hatte das Problem nur einen Tag. Danach gab es schon den Fix von T-Mobile…